Autonomous System:修订间差异

云云​(留言 | 贡献)
创建页面,内容为“{{Infobox | 标题 = Autonomous System | 内容 = {{!}}- ! 中文名 {{!}} 自治系统 {{!}}- ! 英文名 {{!}} Autonomous System {{!}}- ! 缩写 {{!}} AS {{!}}- ! 标识符 {{!}} Autonomous System Number(ASN) {{!}}- ! 分类 {{!}} 域间路由单元,路径矢量路由域 {{!}}- ! 关联协议 {{!}} Border Gateway Protocol(BGP) {{!}}- ! 管理机构 {{!}} IANA(全球)、RIRs(区域) }} '''自治系统(Autonomous System, AS)''' 是互联…”
 
IdleTap-bot​(留言 | 贡献)
由旧格式Infobox转换为新参数格式(label/data),修复空信息框(由IdleTap-bot执行)
 
(未显示另一用户的1个中间版本)
第1行: 第1行:
{{Infobox
{{Infobox
| 标题 = Autonomous System
| title = Autonomous System
| 内容 =  
 
{{!}}-
| label1 = 中文名
! 中文名
| data1 = 自治系统
{{!}} 自治系统
 
{{!}}-
| label2 = 英文名
! 英文名
| data2 = Autonomous System
{{!}} Autonomous System
 
{{!}}-
| label3 = 缩写
! 缩写
| data3 = AS
{{!}} AS
 
{{!}}-
| label4 = 标识符
! 标识符
| data4 = Autonomous System Number(ASN)
{{!}} Autonomous System Number(ASN)
 
{{!}}-
| label5 = 分类
! 分类
| data5 = 域间路由单元,路径矢量路由域
{{!}} 域间路由单元,路径矢量路由域
 
{{!}}-
| label6 = 关联协议
! 关联协议
| data6 = Border Gateway Protocol(BGP)
{{!}} Border Gateway Protocol(BGP)
 
{{!}}-
| label7 = 管理机构
! 管理机构
| data7 = IANA(全球)、RIRs(区域)
{{!}} IANA(全球)、RIRs(区域)
}}
}}


'''自治系统(Autonomous System, AS)''' 是互联网中由一个或多个IP前缀组成的集合,由单一技术管理机构控制,并遵循统一的路由策略运行<ref name="RFC1930">[https://datatracker.ietf.org/doc/rfc1930/ Hawkinson, J., Bates, T., "Guidelines for creation, selection, and registration of an Autonomous System (AS)", RFC 1930, BCP 6, March 1996.]</ref><ref name="APNIC_def">[https://blog.apnic.net/2021/03/18/what-exactly-are-asns/ Wilkinson, A., "What, exactly, are ASNs?", APNIC Blog, March 2021.]</ref>。自治系统是外部路由协议(尤其是边界网关协议BGP)中的基本路由单元,BGP在不同AS之间交换网络可达性信息,构成互联网的域间路由基础<ref name="RFC4271_BGP">[https://datatracker.ietf.org/doc/rfc4271/ Rekhter, Y., Li, T., Hares, S., "A Border Gateway Protocol 4 (BGP-4)", RFC 4271, January 2006.]</ref>。每个自治系统通过全局唯一的自治系统号码(Autonomous System Number, ASN)进行标识<ref name="IANA">[https://www.iana.org/assignments/as-numbers/as-numbers.xhtml IANA, "Autonomous System (AS) Numbers", March 2026.]</ref>。
'''自治系统(Autonomous System, AS)''' 是[[互联网]]中由一个或多个IP前缀组成的集合,由单一技术管理机构控制,并遵循统一的路由策略运行<ref name="RFC1930">[https://datatracker.ietf.org/doc/rfc1930/ Hawkinson, J., Bates, T., "Guidelines for creation, selection, and registration of an Autonomous System (AS)", RFC 1930, BCP 6, March 1996.]</ref><ref name="APNIC_def">[https://blog.apnic.net/2021/03/18/what-exactly-are-asns/ Wilkinson, A., "What, exactly, are ASNs?", APNIC Blog, March 2021.]</ref>。自治系统是外部[[路由协议]](尤其是[[边界网关协议]][[BGP]])中的基本路由单元,BGP在不同AS之间交换网络可达性信息,构成互联网的域间路由基础<ref name="RFC4271_BGP">[https://datatracker.ietf.org/doc/rfc4271/ Rekhter, Y., Li, T., Hares, S., "A Border Gateway Protocol 4 (BGP-4)", RFC 4271, January 2006.]</ref>。每个自治系统通过全局唯一的自治系统号码(Autonomous System Number, ASN)进行标识<ref name="IANA">[https://www.iana.org/assignments/as-numbers/as-numbers.xhtml IANA, "Autonomous System (AS) Numbers", March 2026.]</ref>。


== 定义 ==
== 定义 ==
第44行: 第43行:
== ASN格式与分配 ==
== ASN格式与分配 ==


ASN由互联网号码分配机构(IANA)统一管理,IANA将ASN区块分配给各区域互联网注册管理机构(RIRs),RIRs再按区域内的分配政策向网络运营商下发<ref name="IANA" /><ref name="APNIC_reg">[https://www.apnic.net/manage-ip/apnic-services/registration-services/ APNIC, "Resource registration services".]</ref>。全球共有五个RIRs<ref name="IANA" />:
ASN由互联网号码分配机构(IANA)统一管理,IANA将ASN区块分配给各区域互联网注册管理机构(RIRs),RIRs再按区域内的分配政策向网络运营商下发<ref name="IANA" /><ref name="APNIC_reg">[https://www.apnic.net/manage-ip/apnic-services/registration-services/ APNIC, "Resource registration services".]</ref>。[[全球]]共有五个RIRs<ref name="IANA" />:
* AFRINIC(非洲)
* AFRINIC(非洲)
* APNIC(亚太)
* APNIC(亚太)
第88行: 第87行:
AS的概念最早形成于20世纪80年代末至90年代初,与BGP协议的初始设计紧密相关<ref name="APNIC_def" />。1995年的RFC 1771(BGP-4)首次正式定义了AS的含义和作用<ref name="APNIC_def" />。
AS的概念最早形成于20世纪80年代末至90年代初,与BGP协议的初始设计紧密相关<ref name="APNIC_def" />。1995年的RFC 1771(BGP-4)首次正式定义了AS的含义和作用<ref name="APNIC_def" />。


随着IP网络的发展,BGP-4为支持VPN、IPv6等场景演进为多协议BGP扩展(MP-BGP, RFC 4760),各地址族的AS_PATH等属性也得以在MP-BGP框架下承载。
随着IP网络的发展,BGP-4为支持[[VPN]]、IPv6等场景演进为多协议BGP扩展(MP-BGP, RFC 4760),各地址族的AS_PATH等属性也得以在MP-BGP框架下承载。


== 安全考量 ==
== 安全考量 ==