<?xml version="1.0"?>
<feed xmlns="http://www.w3.org/2005/Atom" xml:lang="zh">
	<id>https://130.wiki/index.php?action=history&amp;feed=atom&amp;title=CIDR</id>
	<title>CIDR - 版本历史</title>
	<link rel="self" type="application/atom+xml" href="https://130.wiki/index.php?action=history&amp;feed=atom&amp;title=CIDR"/>
	<link rel="alternate" type="text/html" href="https://130.wiki/index.php?title=CIDR&amp;action=history"/>
	<updated>2026-10-31T17:00:30Z</updated>
	<subtitle>本wiki上该页面的版本历史</subtitle>
	<generator>MediaWiki 1.45.3</generator>
	<entry>
		<id>https://130.wiki/index.php?title=CIDR&amp;diff=7343&amp;oldid=prev</id>
		<title>云云：​重定向页面至无类别域间路由</title>
		<link rel="alternate" type="text/html" href="https://130.wiki/index.php?title=CIDR&amp;diff=7343&amp;oldid=prev"/>
		<updated>2026-09-30T13:46:26Z</updated>

		<summary type="html">&lt;p&gt;重定向页面至&lt;a href=&quot;/wiki/%E6%97%A0%E7%B1%BB%E5%88%AB%E5%9F%9F%E9%97%B4%E8%B7%AF%E7%94%B1&quot; title=&quot;无类别域间路由&quot;&gt;无类别域间路由&lt;/a&gt;&lt;/p&gt;
&lt;table style=&quot;background-color: #fff; color: #202122;&quot; data-mw=&quot;interface&quot;&gt;
				&lt;col class=&quot;diff-marker&quot; /&gt;
				&lt;col class=&quot;diff-content&quot; /&gt;
				&lt;col class=&quot;diff-marker&quot; /&gt;
				&lt;col class=&quot;diff-content&quot; /&gt;
				&lt;tr class=&quot;diff-title&quot; lang=&quot;zh&quot;&gt;
				&lt;td colspan=&quot;2&quot; style=&quot;background-color: #fff; color: #202122; text-align: center;&quot;&gt;←上一版本&lt;/td&gt;
				&lt;td colspan=&quot;2&quot; style=&quot;background-color: #fff; color: #202122; text-align: center;&quot;&gt;2026年9月30日 (三) 13:46的版本&lt;/td&gt;
				&lt;/tr&gt;&lt;tr&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-lineno&quot; id=&quot;mw-diff-left-l1&quot;&gt;第1行：&lt;/td&gt;
&lt;td colspan=&quot;2&quot; class=&quot;diff-lineno&quot;&gt;第1行：&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;[[无类别域间路由]]&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;+&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #a3d3ff; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;ins style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;#&lt;/ins&gt;重定&lt;ins style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;向 &lt;/ins&gt;[[无类&lt;ins style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;别&lt;/ins&gt;域间路由]]&lt;/div&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;{{Infobox&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;| title = 无类别域间路由&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;| label1 = 中文名&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;| data1 = 无类别域间路由&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;| label2 = 英文名&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;| data2 = Classless Inter-Domain Routing&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;| label3 = 简称&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;| data3 = CIDR&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;| label4 = 提出时间&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;| data4 = 1993年&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;| label5 = 标准化机构&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;| data5 = IETF&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;| label6 = 核心标准&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;| data6 = RFC 1517、RFC 1518、RFC 1519、RFC 4632&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;| label7 = 核心技术&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;| data7 = 可变长子网掩码（VLSM）、路由聚合&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;| label8 = 主要功能&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;| data8 = 提升IPv4地址空间利用效率、抑制全球路由表快速增长&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;}}&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;&#039;&#039;&#039;无类别域间路由（Classless Inter-Domain Routing，CIDR）&#039;&#039;&#039; 是IETF于1993年提出的一项IPv4地址分配与路由优化技术方案，其设计目的在于提升IPv4地址空间的利用效率，并抑制因分类网络体系导致的全局路由表快速增长&amp;lt;ref name=&quot;RFC1519&quot;&amp;gt;[https://www.rfc-editor.org/rfc/rfc1519.html Fuller, V., Li, T., Yu, J., Varadhan, K., &quot;Classless Inter-Domain Routing (CIDR): an Address Assignment and Aggregation Strategy&quot;, RFC 1519, September 1993.]&amp;lt;/ref&amp;gt;&amp;lt;ref name=&quot;KPCIDR&quot;&amp;gt;[https://www.kepuchina.cn/article/articleinfo?ar_id=367636 无类别域间路由，科普中国，2021.]&amp;lt;/ref&amp;gt;。CIDR通过可变长子网掩码实现任意长度的网络前缀分配，使IP地址的划分不再受限于A、B、C类的固定掩码体系&amp;lt;ref name=&quot;KPCIDR&quot; /&amp;gt;，并可基于网络前缀对连续的地址块进行路由聚合以减少路由器需维护的路由条目数量&amp;lt;ref name=&quot;Supernet&quot;&amp;gt;[https://baike.c114.com.cn/view.php?id=14098 超网，通信百科.]&amp;lt;/ref&amp;gt;。该技术是现代[[互联网]]路由体系的基础性技术之一，IPv6协议也延续并采纳了CIDR的地址表示和管理机制。&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;== 历史背景 ==&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;在CIDR被提出之前，IPv4地址采用分类网络体系。IPv4地址的32位按8位一组划分为四个字节，其中网络前缀的长度固定为8位（A类）、16位（B类）或24位（C类），分别对应约1677万、6.5万和256个主机地址容量。至20世纪90年代初，分类网络的局限性日益凸显：A类和B类网络对于绝大多数组织而言地址容量过大，大量地址被分配后闲置而无法回收；C类网络虽然容量较小（仅254个可用主机地址），但其地址块数量庞大，且在地域分布上高度分散，难以进行有效的路由聚合。这一双&lt;/del&gt;重&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;困境导致两方面问题：一是IPv4地址空间面临快速耗尽的危机，二是互联网核心路由器的路由表条目呈爆炸式增长，对路由设备的处理能力和网络可扩展性构成严重威胁&amp;lt;ref name=&quot;RFC1519&quot; /&amp;gt;。&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;分类网络中的B类地址数量有限，仅有16384个。随着接入互联网的组织数量持续增长，B类地址消耗速度远超预期。为应对上述问题，IETF在1993年9月发布了一系列标准文档，正式引入CIDR。其中RFC 1517阐述了CIDR的适用性声明，RFC 1518提出了基于CIDR的IP地址分配[[架构]]，RFC 1519详细规&lt;/del&gt;定&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;了地址分配与聚合策略的具体实施方案&amp;lt;ref name=&quot;RFC1519&quot; /&amp;gt;&amp;lt;ref name=&quot;RFC1517&quot;&amp;gt;[https://www.rfc-editor.org/rfc/rfc1517.html Internet Engineering Steering Group, Hinden, R., &quot;Applicability Statement for the Implementation of Classless Inter-Domain Routing (CIDR)&quot;, RFC 1517, September 1993.]&amp;lt;/ref&amp;gt;&amp;lt;ref name=&quot;RFC1518&quot;&amp;gt;[https://www.rfc-editor.org/rfc/rfc1518.html Rekhter, Y., Li, T., &quot;An Architecture for IP Address Allocation with CIDR&quot;, RFC 1518, September 1993.]&amp;lt;/ref&amp;gt;。2006年，RFC 4632替代并更新了RFC 1519，在对CIDR概念进行进一步澄清的基础上，总结了该技术实际部署十余年的实践经验&amp;lt;ref name=&quot;RFC4632&quot;&amp;gt;[https://www.rfc-editor.org/rfc/rfc4632.html Fuller, V., Li, T., &quot;Classless Inter-domain Routing (CIDR): The Internet Address Assignment and Aggregation Plan&quot;, RFC 4632, BCP 122, August 2006.]&amp;lt;/ref&amp;gt;&amp;lt;ref name=&quot;RFC4632Info&quot;&amp;gt;&lt;/del&gt;[&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;https://www.rfc-editor.org/info/rfc4632 Information on RFC 4632, RFC Editor.]&amp;lt;/ref&amp;gt;。&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;== 核心技术 ==&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;=== 可变长子网掩码 ===&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;CIDR的基础是可变长子网掩码技术。VLSM允许网络工程师根据子网的实际主机数量需求，灵活设定子网掩码的长度，而非被固定为A、B、C类掩码中的三者之一&amp;lt;ref name=&quot;VLSMvsCIDR&quot;&amp;gt;&lt;/del&gt;[&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;https://net.zhiding.cn/network_security_zone/2008/0514/747195.shtml 思科学习总结：认识VLSM与CIDR，至顶网，2008.]&amp;lt;/ref&amp;gt;。VLSM的概念早在1985年的RFC 950中即已出现，而CIDR则将其推广至整个地址空间，彻底消除了分类网络的边界&amp;lt;ref name=&quot;KPCIDR&quot; /&amp;gt;。&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;在CIDR框架中，IP地址被划分为网络前缀和主机号两部分，网络前缀的长度用“/”后跟0至32之间的整数表示。例如，192.168.1.0/24表示前24位为网络前缀，后8位为主机号，该地址块包含256个IP地址。前缀长度越短，地址块包含的IP地址数量越多；前缀长度越长，地址块划分越精细，地址利用率越高。CIDR不再使用“子网”的概念而使用网络前缀来表示网络标识&amp;lt;ref name=&quot;SupernetBaike&quot;&amp;gt;[https://baike.baidu.com/item/%E8%B6%85%E7%BD%91 超网，百度百科.]&amp;lt;/ref&amp;gt;。&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;=== 路由聚合 ===&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;路由聚合是CIDR的另一项核心技术，亦称为构成超网或路由汇总&amp;lt;ref name=&quot;SupernetIT&quot;&amp;gt;[https://net.it168.com/info/2022-11-17/2022111711115724.shtml IPv4：超网，你是我的“神”！，IT168，2022.]&amp;lt;/ref&amp;gt;。其基本原理是：如果多个较小的地址块在[[二进制]]表示下前缀相同，则可以将它们合并为一个较大的CIDR地址块，并在路由表中以一条聚合条目代表原来分散的多条路由记录&amp;lt;ref name=&quot;Supernet&quot; /&amp;gt;。这一操作被称为路由聚合，聚合后的地址块在网络中对外通告时被视为一个整体，可使路由表中的一条记录代表原来传统分类地址的多条路由记录，从而显著减少路由表中的路由记录数量&amp;lt;ref name=&quot;Supernet&quot; /&amp;gt;。&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;路由聚合的有效性依赖于合理的地址分配规划。当同一机构或同一地理区域的地址块在地址空间上连续时，聚合效果最佳；当地址分配策略缺乏层次性时，聚合的效率则会大打折扣。CIDR支持的路由聚合能够将路由表中的许多路由条目合并为成更少的数目，从而限制路由器中路由表的增大，减少路由通告，提高网络可扩展性&amp;lt;ref name=&quot;CIDRAggr&quot;&amp;gt;[https://net.zhiding.cn/network_security_zone/2010/0202/1687640.shtml &lt;/del&gt;无类域间&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;路由CIDR，至顶网，2010.]&amp;lt;/ref&amp;gt;。&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;== CIDR表示法 ==&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;CIDR表示法也称斜线记法，其标准格式为“IPv4地址/前缀长度”。其中，IPv4地址部分可以是该地址块内的任一合法IP地址；前缀长度是从0到32之间的十进制整数，表示网络前缀所占的二进制位数&amp;lt;ref name=&quot;SlashNotation&quot;&amp;gt;[https://internet.hactcm.edu.cn/network/lesson/cidr/cidr_notation.html CIDR斜线记法.]&amp;lt;/ref&amp;gt;。前缀长度决定子网掩码：将前N位置1、后32-N位置0即得到对应的子网掩码。&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;以下为CIDR表示法示例：&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;* 192.168.0.0/16：前16位为网络前缀，对应子网掩码255.255.0.0，包含65536个IPv4地址。&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;* 10.0.0.0/8：前8位为网络前缀，对应子网掩码255.0.0.0，包含16777216个IPv4地址。&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;* 203.0.113.0/27：前27位为网络前缀，对应子网掩码255.255.255.224，包含32个IPv4地址，其中30个可用主机地址。&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;* 0.0.0.0/0：前缀长度为0，匹配所有IPv4地址，通常作为默认路由使用。&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;== 地址分配与管理 ==&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;CIDR将IPv4地址分配从以网络类别为依据的模式转变为以实际需求为依据的模式。在CIDR框架下，IANA将大块的CIDR地址块分配给各区域互联网注册管理机构（RIRs），RIRs再根据下级机构（如国家级注册机构和ISP）的实际需求，将地址块切分为更小的CIDR块进行逐级分配&amp;lt;ref name=&quot;RFC4632&quot; /&amp;gt;。&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;这一层级化分配体系与路由聚合的要求相呼应：ISP从RIR获得一个较大的CIDR地址块后，可将其子块分配给下属客户。所有客户的&lt;/del&gt;路由&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;信息在ISP边界进行聚合，以单一聚合路由对外通告，从而使上游路由器无需维护大量细粒度路由条目。由于一个CIDR地址块中含有很多地址，在路由表中可利用CIDR地址块来查找目标网络，这种地址的聚合常称为路由聚合或构成超网&amp;lt;ref name=&quot;SupernetKoolearn&quot;&amp;gt;[https://m.koolearn.com/shiti/tiku-20585974.html 构造超网，新东方在线，2024.]&amp;lt;/ref&amp;gt;。&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;== 协议支持 ==&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;CIDR需要在[[路由协议]]层面获得相应支持才能正常工作。支持CIDR的路由协议被称为无类路由协议，它们在路由更新中携带子网掩码信息，从而具备识别任意长度网络前缀的能力&amp;lt;ref name=&quot;CIDRandClassful&quot;&amp;gt;[https://datatracker.ietf.org/doc/rfc1817/ Rekhter, Y., &quot;CIDR and Classful Routing&quot;, RFC 1817, August 1995.]&amp;lt;/ref&amp;gt;。常见的无类路由协议包括：&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;* 内部网关协议：RIPv2、OSPF、IS-IS（集成版本）、EIGRP&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;* [[外部网关协议]]：[[BGP]]-4&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;不支持CIDR的路由协议包括RIPv1、BGP-3、EGP以及Cisco专有的IGRP等早期协议&amp;lt;ref name=&quot;RFC1817&quot; /&amp;gt;。BGP-4支持CIDR，在路由更新时只发送更新的路由，大大减少了BGP传播路由所占用的带宽，适用于在Internet上传播大量的路由信息&amp;lt;ref name=&quot;H3CBGP&quot;&amp;gt;[https://www.h3c.com/cn/Products_Technology/Technology/BGP/ BGP技术介绍，H3C.&lt;/del&gt;]&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;&amp;lt;/ref&amp;gt;。&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;== 与VLSM的关系 ==&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;CIDR与VLSM是两项相互关联的技术，但它们的应用方向相反：VLSM将一个标准的网络划分成几个小型网络（子网），以提高IP地址的利用率；CIDR则将几个小型的网络合成一个大的网络（超网），以减少路由表中的条目数量&amp;lt;ref name=&quot;CIDRvsVLSM&quot;&amp;gt;[https://developer.baidu.com/article/details/2589224 CIDR与VLSM：网络地址规划的双重策略，百度开发者中心，2024.&lt;/del&gt;]&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;&amp;lt;/ref&amp;gt;。从历史发展来看，RFC 950（1985）中定义的可变长子网掩码概念早于CIDR&amp;lt;ref name=&quot;KPCIDR&quot; /&amp;gt;，但两者在本质上共享相同的基础——即根据实际需求使用灵活长度的网络前缀，而非固定长度的网络号。&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;== 局限性与后续发展 ==&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;CIDR虽然有效缓解了IPv4地址消耗速度并抑制了路由表的增长，但其设计的根本前提仍然是32位IPv4地址空间的有限性。地址空间的总量并未因CIDR的引入而增加，CIDR并不能从根本上阻止IPv4地址的最终耗尽。为应对CIDR无法解决的地址短缺问题，网络地址转换技术在后续几年中被广泛部署，作为另一项延长IPv4存续期的过渡方案。从长期来看，从IPv4向IPv6的彻底迁移才是解决地址匮乏问题的最终手段。IPv6协议在设计上全面采纳了CIDR的地址表示与路由聚合机制，IPv6地址的书写标准格式即为“IPv6地址/前缀长度”的CIDR记法&amp;lt;ref name=&quot;CIDRAggr&quot; /&amp;gt;。&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;== 参考文献 ==&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt; &lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;
&lt;tr&gt;&lt;td class=&quot;diff-marker&quot; data-marker=&quot;−&quot;&gt;&lt;/td&gt;&lt;td style=&quot;color: #202122; font-size: 88%; border-style: solid; border-width: 1px 1px 1px 4px; border-radius: 0.33em; border-color: #ffe49c; vertical-align: top; white-space: pre-wrap;&quot;&gt;&lt;div&gt;&lt;del style=&quot;font-weight: bold; text-decoration: none;&quot;&gt;&amp;lt;references /&amp;gt;&lt;/del&gt;&lt;/div&gt;&lt;/td&gt;&lt;td colspan=&quot;2&quot; class=&quot;diff-side-added&quot;&gt;&lt;/td&gt;&lt;/tr&gt;

&lt;!-- diff cache key 130.wiki::diff:1.41:old-6288:rev-7343:php=table --&gt;
&lt;/table&gt;</summary>
		<author><name>云云</name></author>
	</entry>
	<entry>
		<id>https://130.wiki/index.php?title=CIDR&amp;diff=6288&amp;oldid=prev</id>
		<title>IdleTap-bot：​由旧格式Infobox转换为新参数格式（label/data），修复空信息框（由IdleTap-bot执行）</title>
		<link rel="alternate" type="text/html" href="https://130.wiki/index.php?title=CIDR&amp;diff=6288&amp;oldid=prev"/>
		<updated>2026-08-11T10:12:26Z</updated>

		<summary type="html">&lt;p&gt;由旧格式Infobox转换为新参数格式（label/data），修复空信息框（由IdleTap-bot执行）&lt;/p&gt;
&lt;a href=&quot;https://130.wiki/index.php?title=CIDR&amp;amp;diff=6288&amp;amp;oldid=1293&quot;&gt;显示更改&lt;/a&gt;</summary>
		<author><name>IdleTap-bot</name></author>
	</entry>
	<entry>
		<id>https://130.wiki/index.php?title=CIDR&amp;diff=1293&amp;oldid=prev</id>
		<title>TeodoroSeccombe：​创建页面，内容为“。”</title>
		<link rel="alternate" type="text/html" href="https://130.wiki/index.php?title=CIDR&amp;diff=1293&amp;oldid=prev"/>
		<updated>2026-07-15T21:04:27Z</updated>

		<summary type="html">&lt;p&gt;创建页面，内容为“。”&lt;/p&gt;
&lt;a href=&quot;https://130.wiki/index.php?title=CIDR&amp;amp;diff=1293&amp;amp;oldid=744&quot;&gt;显示更改&lt;/a&gt;</summary>
		<author><name>TeodoroSeccombe</name></author>
	</entry>
	<entry>
		<id>https://130.wiki/index.php?title=CIDR&amp;diff=744&amp;oldid=prev</id>
		<title>云云：​创建页面，内容为“无类别域间路由  {{Infobox | 标题 = 无类别域间路由 | 内容 =  {{!}}- ! 中文名 {{!}} 无类别域间路由 {{!}}- ! 英文名 {{!}} Classless Inter-Domain Routing {{!}}- ! 简称 {{!}} CIDR {{!}}- ! 提出时间 {{!}} 1993年 {{!}}- ! 标准化机构 {{!}} IETF {{!}}- ! 核心标准 {{!}} RFC 1517、RFC 1518、RFC 1519、RFC 4632 {{!}}- ! 核心技术 {{!}} 可变长子网掩码（VLSM）、路由聚合 {{!}}- ! 主要功能 {{!}} 提升IPv4…”</title>
		<link rel="alternate" type="text/html" href="https://130.wiki/index.php?title=CIDR&amp;diff=744&amp;oldid=prev"/>
		<updated>2026-06-14T16:01:19Z</updated>

		<summary type="html">&lt;p&gt;创建页面，内容为“无类别域间路由  {{Infobox | 标题 = 无类别域间路由 | 内容 =  {{!}}- ! 中文名 {{!}} 无类别域间路由 {{!}}- ! 英文名 {{!}} Classless Inter-Domain Routing {{!}}- ! 简称 {{!}} CIDR {{!}}- ! 提出时间 {{!}} 1993年 {{!}}- ! 标准化机构 {{!}} IETF {{!}}- ! 核心标准 {{!}} RFC 1517、RFC 1518、RFC 1519、RFC 4632 {{!}}- ! 核心技术 {{!}} 可变长子网掩码（VLSM）、路由聚合 {{!}}- ! 主要功能 {{!}} 提升IPv4…”&lt;/p&gt;
&lt;p&gt;&lt;b&gt;新页面&lt;/b&gt;&lt;/p&gt;&lt;div&gt;无类别域间路由&lt;br /&gt;
&lt;br /&gt;
{{Infobox&lt;br /&gt;
| 标题 = 无类别域间路由&lt;br /&gt;
| 内容 = &lt;br /&gt;
{{!}}-&lt;br /&gt;
! 中文名&lt;br /&gt;
{{!}} 无类别域间路由&lt;br /&gt;
{{!}}-&lt;br /&gt;
! 英文名&lt;br /&gt;
{{!}} Classless Inter-Domain Routing&lt;br /&gt;
{{!}}-&lt;br /&gt;
! 简称&lt;br /&gt;
{{!}} CIDR&lt;br /&gt;
{{!}}-&lt;br /&gt;
! 提出时间&lt;br /&gt;
{{!}} 1993年&lt;br /&gt;
{{!}}-&lt;br /&gt;
! 标准化机构&lt;br /&gt;
{{!}} IETF&lt;br /&gt;
{{!}}-&lt;br /&gt;
! 核心标准&lt;br /&gt;
{{!}} RFC 1517、RFC 1518、RFC 1519、RFC 4632&lt;br /&gt;
{{!}}-&lt;br /&gt;
! 核心技术&lt;br /&gt;
{{!}} 可变长子网掩码（VLSM）、路由聚合&lt;br /&gt;
{{!}}-&lt;br /&gt;
! 主要功能&lt;br /&gt;
{{!}} 提升IPv4地址空间利用效率、抑制全球路由表快速增长&lt;br /&gt;
}}&lt;br /&gt;
&lt;br /&gt;
&amp;#039;&amp;#039;&amp;#039;无类别域间路由（Classless Inter-Domain Routing，CIDR）&amp;#039;&amp;#039;&amp;#039; 是IETF于1993年提出的一项IPv4地址分配与路由优化技术方案，其设计目的在于提升IPv4地址空间的利用效率，并抑制因分类网络体系导致的全局路由表快速增长&amp;lt;ref name=&amp;quot;RFC1519&amp;quot;&amp;gt;[https://www.rfc-editor.org/rfc/rfc1519.html Fuller, V., Li, T., Yu, J., Varadhan, K., &amp;quot;Classless Inter-Domain Routing (CIDR): an Address Assignment and Aggregation Strategy&amp;quot;, RFC 1519, September 1993.]&amp;lt;/ref&amp;gt;&amp;lt;ref name=&amp;quot;KPCIDR&amp;quot;&amp;gt;[https://www.kepuchina.cn/article/articleinfo?ar_id=367636 无类别域间路由，科普中国，2021.]&amp;lt;/ref&amp;gt;。CIDR通过可变长子网掩码实现任意长度的网络前缀分配，使IP地址的划分不再受限于A、B、C类的固定掩码体系&amp;lt;ref name=&amp;quot;KPCIDR&amp;quot; /&amp;gt;，并可基于网络前缀对连续的地址块进行路由聚合以减少路由器需维护的路由条目数量&amp;lt;ref name=&amp;quot;Supernet&amp;quot;&amp;gt;[https://baike.c114.com.cn/view.php?id=14098 超网，通信百科.]&amp;lt;/ref&amp;gt;。该技术是现代互联网路由体系的基础性技术之一，IPv6协议也延续并采纳了CIDR的地址表示和管理机制。&lt;br /&gt;
&lt;br /&gt;
== 历史背景 ==&lt;br /&gt;
&lt;br /&gt;
在CIDR被提出之前，IPv4地址采用分类网络体系。IPv4地址的32位按8位一组划分为四个字节，其中网络前缀的长度固定为8位（A类）、16位（B类）或24位（C类），分别对应约1677万、6.5万和256个主机地址容量。至20世纪90年代初，分类网络的局限性日益凸显：A类和B类网络对于绝大多数组织而言地址容量过大，大量地址被分配后闲置而无法回收；C类网络虽然容量较小（仅254个可用主机地址），但其地址块数量庞大，且在地域分布上高度分散，难以进行有效的路由聚合。这一双重困境导致两方面问题：一是IPv4地址空间面临快速耗尽的危机，二是互联网核心路由器的路由表条目呈爆炸式增长，对路由设备的处理能力和网络可扩展性构成严重威胁&amp;lt;ref name=&amp;quot;RFC1519&amp;quot; /&amp;gt;。&lt;br /&gt;
&lt;br /&gt;
分类网络中的B类地址数量有限，仅有16384个。随着接入互联网的组织数量持续增长，B类地址消耗速度远超预期。为应对上述问题，IETF在1993年9月发布了一系列标准文档，正式引入CIDR。其中RFC 1517阐述了CIDR的适用性声明，RFC 1518提出了基于CIDR的IP地址分配架构，RFC 1519详细规定了地址分配与聚合策略的具体实施方案&amp;lt;ref name=&amp;quot;RFC1519&amp;quot; /&amp;gt;&amp;lt;ref name=&amp;quot;RFC1517&amp;quot;&amp;gt;[https://www.rfc-editor.org/rfc/rfc1517.html Internet Engineering Steering Group, Hinden, R., &amp;quot;Applicability Statement for the Implementation of Classless Inter-Domain Routing (CIDR)&amp;quot;, RFC 1517, September 1993.]&amp;lt;/ref&amp;gt;&amp;lt;ref name=&amp;quot;RFC1518&amp;quot;&amp;gt;[https://www.rfc-editor.org/rfc/rfc1518.html Rekhter, Y., Li, T., &amp;quot;An Architecture for IP Address Allocation with CIDR&amp;quot;, RFC 1518, September 1993.]&amp;lt;/ref&amp;gt;。2006年，RFC 4632替代并更新了RFC 1519，在对CIDR概念进行进一步澄清的基础上，总结了该技术实际部署十余年的实践经验&amp;lt;ref name=&amp;quot;RFC4632&amp;quot;&amp;gt;[https://www.rfc-editor.org/rfc/rfc4632.html Fuller, V., Li, T., &amp;quot;Classless Inter-domain Routing (CIDR): The Internet Address Assignment and Aggregation Plan&amp;quot;, RFC 4632, BCP 122, August 2006.]&amp;lt;/ref&amp;gt;&amp;lt;ref name=&amp;quot;RFC4632Info&amp;quot;&amp;gt;[https://www.rfc-editor.org/info/rfc4632 Information on RFC 4632, RFC Editor.]&amp;lt;/ref&amp;gt;。&lt;br /&gt;
&lt;br /&gt;
== 核心技术 ==&lt;br /&gt;
&lt;br /&gt;
=== 可变长子网掩码 ===&lt;br /&gt;
&lt;br /&gt;
CIDR的基础是可变长子网掩码技术。VLSM允许网络工程师根据子网的实际主机数量需求，灵活设定子网掩码的长度，而非被固定为A、B、C类掩码中的三者之一&amp;lt;ref name=&amp;quot;VLSMvsCIDR&amp;quot;&amp;gt;[https://net.zhiding.cn/network_security_zone/2008/0514/747195.shtml 思科学习总结：认识VLSM与CIDR，至顶网，2008.]&amp;lt;/ref&amp;gt;。VLSM的概念早在1985年的RFC 950中即已出现，而CIDR则将其推广至整个地址空间，彻底消除了分类网络的边界&amp;lt;ref name=&amp;quot;KPCIDR&amp;quot; /&amp;gt;。&lt;br /&gt;
&lt;br /&gt;
在CIDR框架中，IP地址被划分为网络前缀和主机号两部分，网络前缀的长度用“/”后跟0至32之间的整数表示。例如，192.168.1.0/24表示前24位为网络前缀，后8位为主机号，该地址块包含256个IP地址。前缀长度越短，地址块包含的IP地址数量越多；前缀长度越长，地址块划分越精细，地址利用率越高。CIDR不再使用“子网”的概念而使用网络前缀来表示网络标识&amp;lt;ref name=&amp;quot;SupernetBaike&amp;quot;&amp;gt;[https://baike.baidu.com/item/%E8%B6%85%E7%BD%91 超网，百度百科.]&amp;lt;/ref&amp;gt;。&lt;br /&gt;
&lt;br /&gt;
=== 路由聚合 ===&lt;br /&gt;
&lt;br /&gt;
路由聚合是CIDR的另一项核心技术，亦称为构成超网或路由汇总&amp;lt;ref name=&amp;quot;SupernetIT&amp;quot;&amp;gt;[https://net.it168.com/info/2022-11-17/2022111711115724.shtml IPv4：超网，你是我的“神”！，IT168，2022.]&amp;lt;/ref&amp;gt;。其基本原理是：如果多个较小的地址块在二进制表示下前缀相同，则可以将它们合并为一个较大的CIDR地址块，并在路由表中以一条聚合条目代表原来分散的多条路由记录&amp;lt;ref name=&amp;quot;Supernet&amp;quot; /&amp;gt;。这一操作被称为路由聚合，聚合后的地址块在网络中对外通告时被视为一个整体，可使路由表中的一条记录代表原来传统分类地址的多条路由记录，从而显著减少路由表中的路由记录数量&amp;lt;ref name=&amp;quot;Supernet&amp;quot; /&amp;gt;。&lt;br /&gt;
&lt;br /&gt;
路由聚合的有效性依赖于合理的地址分配规划。当同一机构或同一地理区域的地址块在地址空间上连续时，聚合效果最佳；当地址分配策略缺乏层次性时，聚合的效率则会大打折扣。CIDR支持的路由聚合能够将路由表中的许多路由条目合并为成更少的数目，从而限制路由器中路由表的增大，减少路由通告，提高网络可扩展性&amp;lt;ref name=&amp;quot;CIDRAggr&amp;quot;&amp;gt;[https://net.zhiding.cn/network_security_zone/2010/0202/1687640.shtml 无类域间路由CIDR，至顶网，2010.]&amp;lt;/ref&amp;gt;。&lt;br /&gt;
&lt;br /&gt;
== CIDR表示法 ==&lt;br /&gt;
&lt;br /&gt;
CIDR表示法也称斜线记法，其标准格式为“IPv4地址/前缀长度”。其中，IPv4地址部分可以是该地址块内的任一合法IP地址；前缀长度是从0到32之间的十进制整数，表示网络前缀所占的二进制位数&amp;lt;ref name=&amp;quot;SlashNotation&amp;quot;&amp;gt;[https://internet.hactcm.edu.cn/network/lesson/cidr/cidr_notation.html CIDR斜线记法.]&amp;lt;/ref&amp;gt;。前缀长度决定子网掩码：将前N位置1、后32-N位置0即得到对应的子网掩码。&lt;br /&gt;
&lt;br /&gt;
以下为CIDR表示法示例：&lt;br /&gt;
&lt;br /&gt;
* 192.168.0.0/16：前16位为网络前缀，对应子网掩码255.255.0.0，包含65536个IPv4地址。&lt;br /&gt;
* 10.0.0.0/8：前8位为网络前缀，对应子网掩码255.0.0.0，包含16777216个IPv4地址。&lt;br /&gt;
* 203.0.113.0/27：前27位为网络前缀，对应子网掩码255.255.255.224，包含32个IPv4地址，其中30个可用主机地址。&lt;br /&gt;
* 0.0.0.0/0：前缀长度为0，匹配所有IPv4地址，通常作为默认路由使用。&lt;br /&gt;
&lt;br /&gt;
== 地址分配与管理 ==&lt;br /&gt;
&lt;br /&gt;
CIDR将IPv4地址分配从以网络类别为依据的模式转变为以实际需求为依据的模式。在CIDR框架下，IANA将大块的CIDR地址块分配给各区域互联网注册管理机构（RIRs），RIRs再根据下级机构（如国家级注册机构和ISP）的实际需求，将地址块切分为更小的CIDR块进行逐级分配&amp;lt;ref name=&amp;quot;RFC4632&amp;quot; /&amp;gt;。&lt;br /&gt;
&lt;br /&gt;
这一层级化分配体系与路由聚合的要求相呼应：ISP从RIR获得一个较大的CIDR地址块后，可将其子块分配给下属客户。所有客户的路由信息在ISP边界进行聚合，以单一聚合路由对外通告，从而使上游路由器无需维护大量细粒度路由条目。由于一个CIDR地址块中含有很多地址，在路由表中可利用CIDR地址块来查找目标网络，这种地址的聚合常称为路由聚合或构成超网&amp;lt;ref name=&amp;quot;SupernetKoolearn&amp;quot;&amp;gt;[https://m.koolearn.com/shiti/tiku-20585974.html 构造超网，新东方在线，2024.]&amp;lt;/ref&amp;gt;。&lt;br /&gt;
&lt;br /&gt;
== 协议支持 ==&lt;br /&gt;
&lt;br /&gt;
CIDR需要在路由协议层面获得相应支持才能正常工作。支持CIDR的路由协议被称为无类路由协议，它们在路由更新中携带子网掩码信息，从而具备识别任意长度网络前缀的能力&amp;lt;ref name=&amp;quot;CIDRandClassful&amp;quot;&amp;gt;[https://datatracker.ietf.org/doc/rfc1817/ Rekhter, Y., &amp;quot;CIDR and Classful Routing&amp;quot;, RFC 1817, August 1995.]&amp;lt;/ref&amp;gt;。常见的无类路由协议包括：&lt;br /&gt;
&lt;br /&gt;
* 内部网关协议：RIPv2、OSPF、IS-IS（集成版本）、EIGRP&lt;br /&gt;
* 外部网关协议：BGP-4&lt;br /&gt;
&lt;br /&gt;
不支持CIDR的路由协议包括RIPv1、BGP-3、EGP以及Cisco专有的IGRP等早期协议&amp;lt;ref name=&amp;quot;RFC1817&amp;quot; /&amp;gt;。BGP-4支持CIDR，在路由更新时只发送更新的路由，大大减少了BGP传播路由所占用的带宽，适用于在Internet上传播大量的路由信息&amp;lt;ref name=&amp;quot;H3CBGP&amp;quot;&amp;gt;[https://www.h3c.com/cn/Products_Technology/Technology/BGP/ BGP技术介绍，H3C.]&amp;lt;/ref&amp;gt;。&lt;br /&gt;
&lt;br /&gt;
== 与VLSM的关系 ==&lt;br /&gt;
&lt;br /&gt;
CIDR与VLSM是两项相互关联的技术，但它们的应用方向相反：VLSM将一个标准的网络划分成几个小型网络（子网），以提高IP地址的利用率；CIDR则将几个小型的网络合成一个大的网络（超网），以减少路由表中的条目数量&amp;lt;ref name=&amp;quot;CIDRvsVLSM&amp;quot;&amp;gt;[https://developer.baidu.com/article/details/2589224 CIDR与VLSM：网络地址规划的双重策略，百度开发者中心，2024.]&amp;lt;/ref&amp;gt;。从历史发展来看，RFC 950（1985）中定义的可变长子网掩码概念早于CIDR&amp;lt;ref name=&amp;quot;KPCIDR&amp;quot; /&amp;gt;，但两者在本质上共享相同的基础——即根据实际需求使用灵活长度的网络前缀，而非固定长度的网络号。&lt;br /&gt;
&lt;br /&gt;
== 局限性与后续发展 ==&lt;br /&gt;
&lt;br /&gt;
CIDR虽然有效缓解了IPv4地址消耗速度并抑制了路由表的增长，但其设计的根本前提仍然是32位IPv4地址空间的有限性。地址空间的总量并未因CIDR的引入而增加，CIDR并不能从根本上阻止IPv4地址的最终耗尽。为应对CIDR无法解决的地址短缺问题，网络地址转换技术在后续几年中被广泛部署，作为另一项延长IPv4存续期的过渡方案。从长期来看，从IPv4向IPv6的彻底迁移才是解决地址匮乏问题的最终手段。IPv6协议在设计上全面采纳了CIDR的地址表示与路由聚合机制，IPv6地址的书写标准格式即为“IPv6地址/前缀长度”的CIDR记法&amp;lt;ref name=&amp;quot;CIDRAggr&amp;quot; /&amp;gt;。&lt;br /&gt;
&lt;br /&gt;
== 参考文献 ==&lt;br /&gt;
&lt;br /&gt;
&amp;lt;references /&amp;gt;&lt;/div&gt;</summary>
		<author><name>云云</name></author>
	</entry>
</feed>